Archive

Posts Tagged ‘oracle’

FRM-92101 – running Oracle Forms using parameters

January 7, 2011 Leave a comment

I’m trying to run a form using URL parameters and I’m getting this error:

FRM-92101:There was a failure in the Forms Server during startup. This could happen due to invalid configuration. Please look into the web-server log file for details.

I take a look at the application log at:

$MIDTIER_HOME/j2ee/<OC4J_FORMS_dir>/application-deployments/<forms_deployment_dir>/<OC4J_FORMS_dir_>default_island_1/application.log

and there is nothing explanatory:

11/01/07 12:23:26 formsweb: Forms session <8> failed during startup: no response from runtime process
11/01/07 12:23:26 formsweb: Forms session <8> exception stack trace:
oracle.forms.engine.RunformException: Forms session <8> failed during startup: no response from runtime process
at oracle.forms.servlet.RunformProcess.connect(Unknown Source)
at oracle.forms.servlet.RunformProcess.dataToRunform(Unknown Source)
at oracle.forms.servlet.RunformSession.dataToRunform(Unknown Source)
at oracle.forms.servlet.ListenerServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:835)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:341)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:816)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:231)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:136)
at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)
at java.lang.Thread.run(Thread.java:534)

After checking logs and reviewing the formsweb.conf again and again, I noticed that I made a silly mistake. I ran a custom configuration changing the default form indicated on the configuration with the form parameter, and I was using the plus sign (+) as parameter separator instead of ampersand (&) (with firefox). Changing the plus sign with the ampersand solved this foolishness:

http://host:7779/forms/frmservlet?config=mike&form=myForm.fmx