Archive

Posts Tagged ‘error’

Install less on Ubuntu with YUI-compressor

February 9, 2013 1 comment

Some days ago I’ve been testing twitter bootstrap and I’m very interested on using less on my projects.

Less brings programming into CSS files. Learn more about less in the less website.

To compile the .less files in Ubuntu, first install the requiered packages [please refer to the updated note at the end of the post]:

$ sudo apt-get install lessc

Now you can create your first less file:

@color: #4D926F;

#header {
  color: @color;
}
h2 {
  color: @color;
}

and compile it:


$ lessc my_first_less_file.less

#header {
 color: #4d926f;
}
h2 {
 color: #4d926f;
}

You can redirect the standard otuput to a file to get the css file:

$ lessc my_first_less_file.less > my_first_less_file.css

To output the minified CSS, just add the -x option:

$ lessc -x my_first_less_file.less
#header{color:#4d926f;}
h2{color:#4d926f;}

You can also use the YUI Compressor with less:


$ lessc --yui-compress my_first_less_file.less
#header {
 color: #4d926f;
}
h2 {
 color: #4d926f;
}

Yep! Something’s wrong… Is there an error with less –yui-compress?

I think there’s a problem with the –yui-compress option.

To workaround this, I’ve installed yui-compressor:


$ sudo apt-get install yui-compressor

<em id="__mceDel">

Now, I generate  the css with lessc and then compress it with YUI:


$ lessc --yui-compress my_first_less_file.less > my_first_less_file.css

$ yui-compressor my_first_less_file.css

#header{color:#4d926f}h2{color:#4d926f}

I will do further investigation about the less –yui-compress fail.

Updated!

I’ve installed the incorrect version of less, and the –yui-compress was not working:

I previously installed this packages:

<pre>$ sudo apt-get install libc-ares2 libev4  libnode-less libv8-3.1.8.22 nodejs

But this installs an old version of less:


$ lessc --version
lessc 1.1.0 (LESS Compiler) [JavaScript]

$ sudo apt-get remove lessc --purge

$ sudo apt-get install lessc

$ lessc --version
lessc 1.3.3 (LESS Compiler) [JavaScript]

Now I can compile with –yui-compress working!

PHPMyAdmin – Error – Cannot start session without errors

September 19, 2012 Leave a comment

When I access to PHPMyAdmin I get this error:


phpMyAdmin - Error

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

My Apache error log shows nothing about PHP errors.

I’ve cleaned up the cookies and not it works.

Categories: apache, MySQL, php Tags: , ,

Problems with flash in chrome for ubuntu

April 26, 2012 1 comment

I’m using google chrome on ubuntu 11.10 64 bits.

I have a lot of problems playing flash videos (slow playback, errors in some pages, etc.).

This is how I solved.

Type this on your adress bar:


chrome://plugins

Click on the details link on the upper right corner to see a detailed view.

Search the text “flash”. In my case I have this two plugins:


VLC Multimedia Plugin (compatible Totem 3.0.1)

Shockwave Flash (2 files) - Versió: 10.1 r999.<br>Gnash 0.8.10dev, the GNU SWF Player

I have problems with the gnash plugin, so I removed it. First, close google chrome, and now:

$ sudo apt-get remove gnash

And now install (or reinstall) Adobe’s Flash player plugin:

$ sudo apt-get install flashplugin-installer --reinstall

Now, open again google chrome and in the plugins view you may see Adobe’s Shokwave Flash (in addition to VLC):

Flash - Version: 11.2 r202
VLC Multimedia Plugin (compatible Totem 3.0.1)

If you want, you can reinstall now gnash plugin.

Categories: google apps, ubuntu Tags: , , , , ,

Subclipse/Subversion error on Ubuntu: Failed to load JavaHL Library

November 25, 2011 4 comments

I’ve installed subclipse and when I restart eclipse and try to share a project, I get this error:

The error is:


Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/amd64/server:/usr/lib/jvm/java-6-sun-1.6.0.26/jre/lib/amd64:/usr/lib/jvm/java-6-sun-1.6.0.26/jre/../lib/amd64:/app/oracle/product/10.2.0/db_1/Lib:/usr/lib64/xulrunner-addons:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib

In most of the cases is due to the lack of the libsvn-java library, so just install it:


$ sudo apt-get install libsvn-java

Now you have to tell eclipse where to find this libraries. First, locate where the is:


$sudo updatedb

$ locate libsvnjavahl-1.so
/usr/lib/jni/libsvnjavahl-1.so
/usr/lib/jni/libsvnjavahl-1.so.0
/usr/lib/jni/libsvnjavahl-1.so.0.0.0

Now, edit PATH_TO_ECLIPSE/eclipse.ini and add this line below -vmargs:


-Djava.library.path=/usr/lib/jni

This is my full eclipse.ini with the line already added:

-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.0.v20100503
-product
org.eclipse.epp.package.php.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Djava.library.path=/usr/lib/jni
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx384m

If you still get the error, you’d probably modified the wrong eclipse.ini. In my case, I have a copy of eclipse decompressed in /app folder, but I also have eclipse.ini in /etc, /usr/lib/eclipse and /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.base_6.2.2.20100729-1241/linux/x86/. So, be sure to modify the correct eclipse.ini.

To check if you have modified the correct eclipse.ini, you can follow the Linux troubleshooting section at http://subclipse.tigris.org/wiki/JavaHL.

Install Windows 7 on VirtualBox – Status: error 0xc0000225

November 14, 2011 80 comments

When I try to install Windows 7 on Virtual Box 4.1, I get this error:


Windows failed to start. A recent hardware or software change might be the cause. To fix this problem:

[...]

Status: 0xc0000225

Info: An unexpected error ahs occurred.

VirtualBox - Windows 7 error

Status: 0x0000225

To fix it, stop the virtual machine, go to Settings -> System and check “Enable IO APIC”

Spotify on Ubuntu: “There is a problem with your sound card. Spotify can’t play music”

October 25, 2011 Leave a comment

If you get this error:

There is a problem with your sound card. Spotify can’t play music

Follow this steps:

  1. Close Spotify
  2. In a terminal, type winecfg
  3. Go to the Audio tab
  4. Click “Test Audio” and if you hear a sound go to the next step. If not… you have another problem.
  5. Make sure only OSS Driver is checked in the driver list.
  6. In DirectSound, make sure Hardware Acceleration is Emulation and Default Sample Rate is 44100 and Default Bits Per Sample is 16.
  7. Restart Spotify, you maybe view the mesasge, but if you try to play a song, it dissapears.

Subversion: is already under version control

I’ve deleted a directory from my repository, and then I created one with the same name. When I issue a commit to subversion from eclipse, I get this error:


'<dir>' is already under version control

It means that an invisible .svn folder already exists with the “old” svn data.
To solve it, just removed the .svn folder and it will work again.

Categories: eclipse, subversion Tags: ,