Home > ubuntu > Ubuntu 12.04: Your current Hardware Enablement Stack (HWE) is going out of support on 2014-08-07

Ubuntu 12.04: Your current Hardware Enablement Stack (HWE) is going out of support on 2014-08-07

A few days ago I received a message in the update manager saying that New hardware support is available.

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07. After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.

For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL

But when I try to install, I get an error regarding unmet dependencies.

I tried to update with command-line, as pointed in http://wiki.ubuntu.com/1204_HWE_EOL:


miquel@l3-ubuntu-12:~$ hwe-support-status --verbose

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07. After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.

For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL

To upgrade to a supported (or longer supported) configuration:

* Upgrade from Ubuntu 12.04 LTS to Ubuntu 14.04 LTS by running:
sudo do-release-upgrade

OR

* Install a newer HWE version by running:
sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

and reboot your system.

As my hardware is very old, I decided to install a new HWE version, rather than upgrading to 14.04 LTS, but I’m getting this errors:


$ sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1-mesa-glx-lts-trusty : Depends: libglapi-mesa-lts-trusty (= 10.1.3-0ubuntu0.1~precise1) but it is not going to be installed
Recommends: libgl1-mesa-dri-lts-trusty (>= 7.2) but it is not going to be installed
xserver-xorg-lts-trusty : Recommends: libgl1-mesa-dri-lts-trusty but it is not going to be installed
Recommends: xserver-xorg-input-all-lts-trusty but it is not going to be installed
Recommends: xserver-xorg-video-all-lts-trusty but it is not going to be installed
Recommends: x11-xserver-utils-lts-trusty but it is not going to be installed
Conflicts: libglapi-mesa:i386 (>= 0~)
E: Unable to correct problems, you have held broken packages.
miquel@l3-ubuntu-12:~$ lsb_release -d
Description: Ubuntu 12.04.4 LTS
miquel@l3-ubuntu-12:~$ uname -a
Linux l3-ubuntu-12 3.5.0-54-generic #81~precise1-Ubuntu SMP Tue Jul 15 04:02:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

As posted in http://wiki.ubuntu.com/1204_HWE_EOL:

End-of-life (EOL) for 12.04, 12.04.1, and 12.04.5 HWE is April 2017 but for the other HWE stacks it is roughly when 14.04.1 is released: Aug 8, 2014.

After googling for a while, I found this post in Ubuntu forums: http://ubuntuforums.org/showthread.php?t=2234693. It’s seems safe to stay with the old HWE stack if you are not planning to use new hardware. Security fixes for the kernel will still be released. So, until the update procedure is being more mature, I will stay with the old HWE stack.

Updated 2014-08-11

Thanks to @Michael.Ford comment, I managed to install the new HWE stack following his instructions. I needed a dist-upgrade to finish the installation process.


$ sudo apt-get update

$ sudo apt-get upgrade

$ sudo apt-get dist-upgrade

$ sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty

I was on 3.5.x kernel and now I’m on 3.13.x kernel, and I’m on 12.04.5 LTS release:


$ uname -a
Linux l3-ubuntu-12 3.13.0-33-generic #58~precise1-Ubuntu SMP Wed Jul 30 21:46:30 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.5 LTS"

And now the output of hwe-support-status is different:

$ hwe-support-status --verbose

Your current Hardware Enablement Stack (HWE) is no longer supported
since 2014-08-07. Security updates for critical parts (kernel
and graphics stack) of your system are no longer available.

For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL

There is a graphics stack installed on this system. An upgrade to a 
supported (or longer supported) configuration will become available
on 2014-07-16 and can be invoked by running 'update-manager' in the
Dash.


Thanks again to @Michael.Ford. What’s your opinion about the HWE end of support on Ubuntu 12.04? Have you decided to update to 14.04 LTS? Feel free to comment below.

 

 

 

Advertisements
Categories: ubuntu Tags: , ,
  1. August 12, 2014 at 1:09

    Personaly staying with 12.04 LTS until 16.04 LTS is out. I see no reason to upgrade when everything is working and still supported. Also… would be a pain as I have ~6 Proxmox Vitrual Machines running, all with Ubuntu 12.04.5. For me I think its best to wait fot 16.04.1 then upgrade. It would be the proper LTS -> LTS upgrade cycle anyway.

    Note:
    using that apt-get commnd to install the latest HWE works great and is proper on servers only, as it broke unity on logging back in. However I have a fix.

    Reboot to a prev kernel (ex. 3.2.x I was on), run my cleanKernels script (search it on my blog). then run the following command:

    sudo apt-get install –install-recommends linux-generic-lts-trusty xserver-xorg-lts-trusty libgl1-mesa-glx-lts-trusty

    this will properly install the latest HWE Kernel and Graphics. (was missing graphics thats why unity broke). a kind fellow on Freenode.net #ubuntu irc channel was able to give me that command and works great. Beware though, this will remove WINE. However nothing a simple apt-get install wine cannot fix.

    Like

  2. August 8, 2014 at 23:46

    not getting on my desktop machines. (they were installed with a 12.04.0 ISO, so they do not have HWE to update, and still on 3.2.x mainline kernel) but my servers were installed with 12.04.2 with 3.5.x mainline kernel. Getting the HWE update message. simply ran “sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty” on all of them and was off sailing.

    I would try fully updating your system before appling the Trusty Kernel HWE update
    – run this: “sudo apt-get update ; sudo apt-get upgrade -y ; sudo apt-get dist-upgrade -y”
    allow to update and reboot if another kernel is installed;
    – then run: “sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty”

    its worth a shot.

    Like

    • August 11, 2014 at 18:34

      Thanks! I updated my post with your comments and now I’m on 12.04.5.

      Like

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: